Elevated errors in landing and product pages

Incident Report for Kit

Resolved

Our cloud provider has identified and resolved the incident. We're still monitoring our service, but this can be considered completely solved.
Posted Nov 18, 2025 - 06:58 PST

Investigating

One of our cloud providers is currently experiencing issues and it's impacting the access to our app, landing pages and product pages.
Posted Nov 18, 2025 - 04:13 PST
This incident affected: Application and Integrations.