No components marked as affected
Resolved
This incident has been resolved.
Monitoring
We've finished the infrastructure upgrade and monitoring if it removes the performance degradation.
Identified
We're performing infrastructure upgrades to address the performance issue.
Identified
Thanks for your patience. We are working on our intermittent speed issues.